Jetty ALPN/NPN has not been properly configured.

NO IMAGE

Spring Boot 2.0.0.M4 と Google Cloud Java Client for Pub/Sub 0.25.0-beta を使っていると、下記のようなエラーとなりました。

Jetty ALPN/NPN has not been properly configured. 

Spring Boot 組み込みサーバーを Tomcat から Jetty に変えても同じエラーが。

検索してみると、ドンピシャリの内容がありました。
https://github.com/GoogleCloudPlatform/google-cloud-java/issues/2398

ワークアラウンドとしては、build.gradle の dependencies に下記を追記しておくのがよさそうです。

runtime group: 'io.netty', name: 'netty-tcnative-boringssl-static', version: '2.0.6.Final'

しばらくすれば対応されるでしょう。

Google Cloud Platformカテゴリの最新記事